High hp, str abuse builds have been too strong for too long (Full Version)

All Forums >> [Artix Entertainment Games] >> [EpicDuel] >> EpicDuel Balance



Message


Satafou -> High hp, str abuse builds have been too strong for too long (2/20/2019 5:34:54)

As the title states, the 1700-1900 hp with 660+ primary dmg build has been way too strong for way to long. They literally have base dex, without even putting their enchantments into dex and rarely get blocked, and this has been over way too many battles to be an coincidence. Not to mention it seems fairly common for these builds to go first.

This alone should be reasonable enough for looking into a nerf for hp, however I just want to make it clear, even if i grant myself a 200 P shield in addition to my 400+ def, these builds are still hitting super hard, and if they have the spamable azreal bot there's legit 0 counter play apart from relying on a block which just doesn't seem to occur to these base dex builds. It honestly seems investing into dex is just a punishment for builds, because why do that when u can have an extra 500-600hp right?




Mother1 -> RE: High hp, str abuse builds have been too strong for too long (2/21/2019 9:09:19)

I can vouch for this one. Played some 2 vs 2 a few days ago and me having 100+ more dex than them didn't even help in the least. It doesn't help that the staff made it so people can use the same stat core up to 4 times which only makes the strength abusers even worse.

But to be honest I don't even think a HP penalty will fix this issue.




D3m37r1 -> RE: High hp, str abuse builds have been too strong for too long (3/3/2019 8:50:20)

I've only run into tactical mercs using this build. IMO the problem is toxic grenade. It serves as a single unblockable attack which is huge for those builds. It either needs to have the initial hit damage reduced or just be blockable.




dfo99 -> RE: High hp, str abuse builds have been too strong for too long (3/16/2019 16:53:37)

use katherax bot or bh and it is over for those builds..




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition
0.015625