Home  | Login  | Register  | Help  | Play 

RE: Armor/Weapon/Shield/Spell/Misc/Title Bugs

Logged in as: Guest
  Printable Version
All Forums >> [Artix Entertainment Games] >> [AdventureQuest] >> AdventureQuest Bugs >> RE: Armor/Weapon/Shield/Spell/Misc/Title Bugs
Page 71 of 82«<6970717273>»
Forum Login
Message << Older Topic   Newer Topic >>
7/10/2017 13:34:27   

Purple Rain interacts in a very...questionable manner with items that increase your END and actually increase your current HP up to the new numerical value of the percentage that your current HP makes out of your max HP in general based on your nex max HP (such as the Irt of Osiris) and offensive items that make you pay an HP cost for attacking with them (such as Destruction Burst). I'll describe two scenarios that ended up unfolding in my testing so that the staff may figure out what exactly if the problem from there.

The first scenario is as follows:

Suppose that your character is at full HP for the sake of simplicity. Cast Purple Rain to record the current HP/MP/SP values. Then equip the Irt of Osiris. Then cast Purple Rain properly to reset the HP/MP/SP. This causes your current HP to drop to the amount that you had before equipping the Irt of Osiris while leaving a gap in your HP bar, implying that while your current HP has returned back to its original value your max HP is now stuck at the value that your max HP became equal to when you equipped the Irt of Osiris within the effects of Purple Rain and before you actually used Purple Rain to reset things. However, if after doing all of this you also unequip the Irt of Osiris that you still had equipped after resetting with the Purple Rain your max HP will still be stuck at the increased value as it was before you unequipped the Irt but your current HP will drop even further, actually dropping below your actual max HP that you had at the start of the battle before doing anything of what I have just described.

Also, if you were to perform some sort of attack that doesn't cost HP after doing all of the above and unequipping the Irt you would end up performing it regularly. In addition, if you were to perform some sort of attack that does cost HP (like casting Destruction Burst) after doing all of the above and unequipping the Irt instead of an attack that doesn't cost HP you'd also perform it regulary, with the HP cost being substracted from the lowered amount that you ended up with after unequipping the Irt.

The second scenario if as follows:

Suppose that your character is at full HP for the sake of simplicity. Equip the Irt of Osiris. Then cast Purple Rain to record the current HP/MP/SP values. Then cast Purple Rain properly to reset the HP/MP/SP. At first glance nothing happens and you still have the ammount of HP that you ended up with after equipping the Irt. But if you were to unequip the Irt of using Purple Rain to reset things you'll notice that you'll still be stuck at the amount of HP (both current and max) that you ended up with after equipping the Irt, despite the fact that you just unequipped it.

However, in constrast to the above scenario, if you were to perform some sort of attack that doesn't cost HP after doing all of the above and unequipping the Irt you would see your HP (both current and max, thus leaving no gap in your HP bar) return to the original values that you started the battle with as immediately as you start to perform the attack. On the other hand, if you were to cast Destruction Burst at this point instead of some sort of attack that doesn't cost HP you'll see that your current and max HP will still return to their original values just like if you were to perform an attack that doesn't cost HP at this point. However, that is all that will happen. Your current and max HP will return to those values but the HP cost of Destruction Burst will not be further substracted from that value. Mind, the casting itself will still occur normally in every other way and you'll even still pay the MP cost of Destruction Burst.

...So yeah. That is what I have discovered. However, it bear mention that this happend to an Adventurer of mine on the free server.

< Message edited by RedEyedDrake -- 7/11/2017 12:37:16 >
AQ  Post #: 1751
7/11/2017 7:43:51   

One bug I found and one (possible?) bug I heard of:

Wearing Radiant Aegis (lv115) and Ultimon Armour (lv120) at the start of a battle against a light type, light damaging monster makes the attacks on their first turn deal 0 damage always. (might also work under certain other conditions, pretty sure it has to do with the Radiant Aegis Shield).

When low on mana, equipping Omega Astromorph as someone with above 0 intellect, then using pixel ether to fill your mana bar and then unequipping omega astromorph gives you full mana back. So someone with 200 Int can just cast 5-6 spells and then refill their mana bar for 150sp or so without losing a turn.
AQ  Post #: 1752
7/12/2017 2:06:13   

Whispering raiment and ambush potion initiative bonuses appear to not stack. On the player scroll they are displayed as separate effects.

I have 200 LUK, equipped the whispering raiment, and had the ambush potion active. 200 + 105 + 105 = 410 initiative. Yet undead xyphos (300 luk) went first. 410 vs 300 initiative should guarantee going first, no?

Or is undead xyphos just guaranteed to go first on the first turn?

< Message edited by kittylitter -- 7/12/2017 2:10:05 >
Post #: 1753
7/15/2017 13:15:12   

Apparently this has been reported before but I didn't see on the last 4 pages so I'll just put it here as a reminder.

When casting any burst spell with imbue lore and have any amount of SP available, the imbue lore effect will take away from your SP instead of MP. This is clearly a bug because only burst spells do this in imbue lore, whereas any other spell will take away more from your MP like it's intended to in combination with imbue lore.
Post #: 1754
7/19/2017 13:48:58   

SO i Have an Issue retrieving the Drakonnan Helm Despite beating Unrelenting Undead at least twice logging out and returning hasn't helped and neither has cleaning out my flash cache nor any other try first before you post methods i could do
Post #: 1755
7/23/2017 19:52:18   

Major exploit: Using guardian blade on Angel of souls makes the AoS special attack match the current element of the guardian blade.
Post #: 1756
8/3/2017 23:16:55   

Type of Bug: Incorrect Stat Reset
Has this bug been posted before?: Yes, but no solution or way to reproduce has been stated

Items Bugged: Astramorph Misc items

Bug Details: when swap Shearhide Form to a different armor your stats may be lowered to below it's original stats until logout. higher level of the Astramorph item makes this bug more noticeable.

How to reproduce:
1. Equip the Astramorph preferably the Omega Astramorph
2. Use the Astramorph Item
3. Before the equip animation ends and your stats changes equip a different misc
4. Change to a different armor, your stats will be lowered until you log out

My Original Stats:

My Stats After using this bug once:

My Stats After a few times using this bug:
Post #: 1757
8/3/2017 23:44:17   

I've had this happen to me before and I actually find it pretty difficult to equip the misc fast enough so just be a little careful if you don't want it to happen. There's probably not much the staff can do about that though.
Post #: 1758
8/5/2017 5:29:54   

Bug: Guardian Dragon (from at least both Guardian Blade and Guardian Staff) dealing very low damage to all mobs regardless of HP.
AQ  Post #: 1759
8/7/2017 0:24:45   

guardian blade doesn't seem to change elements anymore from attack.
Post #: 1760
8/11/2017 18:40:07   

Why does guardian dragon keep dealing so little damage?

Edit: this is the character I use http://aq.battleon.com/build30/charview.asp?temp=83473290

it happens vs all monsters at all levels of HP. The damage differs but it's always extremely low. It does not happen on my main character.

< Message edited by Kalle29 -- 8/11/2017 20:58:36 >
AQ  Post #: 1761
8/13/2017 16:59:45   

The Darkovian Bulwark (lvl110) is not activating against vamps/vampires. It does activate against Werewolfs and Werepyres at least.

http://forums2.battleon.com/f/tm.asp?m=22151109 clearly states that it should activate against "vamp"

< Message edited by Saberblade -- 8/13/2017 19:59:49 >
AQ AQW  Post #: 1762
8/20/2017 18:53:19   

The new Righteous Claymores are showing up pink in character profiles.
Post #: 1763
8/26/2017 6:31:36   
Bannished Rogue

Moonwalker's grace spell not getting effects from Generalist Robes.

Generalist Robes:

Title Ability - Arcane Efficiency
If your Class Title is "Wizard", your spells cost less mana
Your Magic spells costs (ClassLevel/2)% less MP, SP, and HP. SP and HP aren't working right now. Melee and Ranged spells are unaffected.

Moonwalker's grace does not receive a reduction in MP cost for some reason, yes I checked to make sure that my class title was set to "wizard" and when highlighting over the skill, it said it was functioning.
AQ DF AQW  Post #: 1764
9/2/2017 13:25:10   

So, I ran into a bug with the new Mecha Knight armor: I used a potion and it turned my weapon-Claimh Solais-into the default sword (though it still did water damage) and when the special triggered it froze and I had to quit the game.

I was using Chrome as my browser, if that's useful information.
AQ DF AQW  Post #: 1765
9/2/2017 14:01:00   

Type of bug: Mutant dragonblade (MDB) no longer triggers against some inherently dragonkind monsters (ex. caecus) or normal monsters after 1 successful cast of Dracomogrify (ex. harpy queen, tadzard) .

Bug details:

Previously 1 successful cast of dracomogrify would trigger the blade and all its effects. This is no longer the case. I believe the issue is with the blade and not the dracomogrify spell because other dragonkind-trigger items (frozen dragonslayer, defensive dragon wand) still trigger after 1 cast of dracomogrify. As further proof, the blade even fails to trigger against caecus even though he is naturally dragonkind whereas the defensive dragon wand triggers automatically, hence this is a problem with no relation to the dracomogrify spell). Note, the MDB does still trigger normally (i.e by default) against drakel (ex. combat trainer, air raider)

Before bug occurred: Normal battling

During Bug: Failure of weapon to change appearance or attempt to swap resistances of a half-dragon foe

After bug: battle continues as normal

Item Bugged: Mutant dragon blade
Other Equipment: any armor, shield, misc, ect combo

Did you log out and log back in? Yes
Did you clear cache? Yes
Did the bug happen again? Yes
Browser Info: Chrome, Safari, Firefox
Post #: 1766
9/21/2017 1:09:50   
Lord Tenebros

The Arcane Cutlasses (at least the Fire one) do not work with Sword Master Emblems, even though they should. I don't know if this is also a problem with the SP regen water cutlass but it's definitely not out of question.
Post #: 1767
10/1/2017 9:37:01   

Right above my no drop armour, I have a "Werewolf Transformation", basically giving me 9 armour slots at the moment...

And I haven't done The Cure or the new Werewolf Subrace release. I simply was a werewolf the entire time. From others I have learnt I oughtn't have this temporary armour.

EDIT: Or is this a feature that is planned but you haven't told us about yet?

Intended. Enjoy your 9th armour. ~IMR

< Message edited by In Media Res -- 10/1/2017 10:55:35 >
AQ  Post #: 1768
10/1/2017 11:53:06   

There is also a bug with the misc Terror Visage from Terror Set.
It doesnt proc the Fear when Snarling in Werewolf Form (Werewolf transformation).
Is it intended due to the way fear stacks? It doesnt seem to proc the fear when using Snarl skill.

< Message edited by LUPUL LUNATIC -- 10/1/2017 14:27:08 >
AQ  Post #: 1769
10/14/2017 16:13:36   
Ella Minnow Pea

I see that somebody already posted here about Darkovian Bulwark not activating against vampires and their kind, but no action has been taken, so I'm reporting it, as well!
AQ  Post #: 1770
10/14/2017 19:00:06   

When using Midnight Savage Werewolf Form if I equip Goggernaut Helm the battle menu disappears and doesn't come back so my only option is to exit the game.
The only way to use the two items together is to equip the helm in a different armor (no problems with them) and then switch to MSWF.
So basically, if I equip Goggernaut Helm anytime while wearing MSWF, the battle menu goes away.
I don't know if the original Savage Werewolf Form does that too, someone else will have to check.
AQ AQW  Post #: 1771
10/15/2017 10:02:29   

^ the same happened when I equipped Iron Golem Helm while on Midnight Savage Werewolf form, seems to have a bug with helm miscs.
AQ  Post #: 1772
10/16/2017 19:36:19   

chrome, 61.0
flash player,

so i bought the new advanced werewolf armor while i was already werewolf class level five and none of my it did not allow me to use any of my abilities.

i tried to return to level 0 and restart the training but i was still not able to use any of the abilities.
i also tried logging out and refreshing and closing the window and clearing the cache but nothing is working.

pls help.
AQ  Post #: 1773
10/16/2017 20:14:05   

You have to do the new quest after training to level 10, just talk to the king one more time. If you are guardian a scaled no drop armor will automatically be added once you complete the quest.
Post #: 1774
10/21/2017 17:25:31   

For the Terror Eater weapon, as well as the Doom Knight Sword and Death's Reaver:

All three do not work correctly against monsters with 0 Darkness resistance. Instead of hitting as though the monster's Darkness resistance is 100% (Eater) or as the monster's weakest element (DoomKnight or Reaver), they all deal zero damage. The bug with the Terror Eater should be fixed quickly especially considering the popularity of the weapon due to its usefulness with Werewolf Armor.
AQ  Post #: 1775
Page:   <<   < prev  69 70 [71] 72 73   next >   >>
All Forums >> [Artix Entertainment Games] >> [AdventureQuest] >> AdventureQuest Bugs >> RE: Armor/Weapon/Shield/Spell/Misc/Title Bugs
Page 71 of 82«<6970717273>»
Jump to:


Icon Legend
New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts

Forum Content Copyright © 2018 Artix Entertainment, LLC.

"AdventureQuest", "DragonFable", "MechQuest", "EpicDuel", "BattleOn.com", "AdventureQuest Worlds", "Artix Entertainment"
and all game character names are either trademarks or registered trademarks of Artix Entertainment, LLC. All rights are reserved.

Forum Software © ASPPlayground.NET Advanced Edition