Home  | Login  | Register  | Help  | Play 

Monster Bugs - read the topic rules BEFORE posting.

 
Logged in as: Guest
  Printable Version
All Forums >> [Artix Entertainment Games] >> [AdventureQuest] >> AdventureQuest Bugs >> Monster Bugs - read the topic rules BEFORE posting.
Page 1 of 6212345>»
Forum Login
Message << Older Topic   Newer Topic >>
9/2/2006 0:10:11   
Icemaster Yeti
Snuggably legendary

 

The following rules still apply:

The Bugs Forum Rules


Things that are NOT bugs:
  • Monster stats do not correspond to level
  • Monsters do not need to damage you to use their regeneration ability.
  • The Phlox does not take damage from your attacks. This is deliberate there is a way to damage it but you'll need to find what it is yourself.
  • Frozen monsters can still block/dodge.
  • Damage numbers with 3 digits get cut off.
  • Werewolf bite does not need to hit to change the player.
  • -1000 luck at start of battle.
  • Most monsters don't use mana when doing magic attacks.
  • Zadd's golems do not attack with their original elements.
  • Hirroo's claw attack reduces your MP, not your HP - same for Braken's water attack.
  • Veegus damaging you if he blocks your attack - he has a counter-attack which will hit you for 10HP
  • Orc Horde's HP won't prematurely go below 1 - you must defeat twelve orcs before you can beat this pack.

Monsters that do not display damage type when hit:

  • Yeti
  • Necrofiend
  • Garganth
  • Vampire Slayer

Graphical flaws:
  • Ice Demon: left shoulder looks disjointed.
  • Darkness dragon: transparent horn.
  • Sunray, bright Sunray, Moonray: doesn't display earth damage icon.
  • Lilliputian Sorcerer Army: doesn't display any damage indicators.
  • Sea Titan: see-through fin on head does not show head behind it.
  • Frost Giant: eyes and teeth are transparent.
  • Ice Bleach: Eyelid turns green halfway down.

Headshots:
  • Water dragon has no headshot.
  • Vampire Lord uses Vampire Warrior head.
  • Cyclops Chieftain uses Cyclops head.
  • Vampire Slayer has no headshot.


KNOWN BUGS THAT DO NOT NEED TO BE REPORTED:

  • Shirrig - Known screen-freeze when using water attacks against him. Provisionally fixed! (Which means you can report it if you have a problem with it. Full details necessary. What you attacked with, what armour you where wearing, did your pet/guest attack ? What pet/guest did you have ? Did it freeze on your turn or on its ? etc)
  • Packs with zombies or orcs in them - a "killed" monster reviving. A "feature" of the pack system when the pack monsters can "heal" or "regenerate".
  • Angel of Darkness - Gives you the Dark Angel Spear automatically after you win. It replaces your no-drop weapon whether you want it or not.
  • Monsters such as Croaker, Sprat, Death Knight, Moglin Death Knight, Wun-dead (etc), which are described as undead in the description, are NOT undead for the purposes of those weapons which trigger on undead. (This is a bug but its one thats slowly being worked on. Chances are you don't need do to mention it) These can now be reported again. All known ones have been fixed.
  • Forest Demon's defence freezing at 0 when you are using a class armour attack menu. Ice Burrower's defenses climb indefinitely when you are using a class armor attack menu. This is fixed on New Class Armors and will be fixed on others as they are redone.
  • Orc Horde: Occasionally freezes in battle. Does not attack and the attack options do not appear Should be fixed
  • Nightraiders: Uneffected by Vampire and Werewolf Strike (if this still happens, it is a flaw with the ability and not the monster and will be fixed when the armor is redone)
  • Undead Party: doesn’t “die” after being defeated
  • Junior Zard Pack: regenerate ability freezing the game Should be fixed
  • Pack glitch: if one of the monsters attacks after you die, you’re thrust into a new battle. This should not happen. If it does, please report DETAILS.
  • Syphon Dracovampiress: Lost stat points don’t fully return. Fixed
  • Kitten of Doom: text runs out of the box.
  • Fire Cobra: Scale Rot does not affect it.
  • Acid Dragon: Freezing the dragon temporarily negates acid damage.
  • Gatta Burpslayer: Text runs out of the box.
  • Fire Orbs: Paralyze turns them into Ice Crystals

    < Message edited by phoenixfire555 -- 10/16/2009 22:52:07 >
  • AQ MQ  Post #: 1
    9/2/2006 9:48:01   
    Jartix
    Banned


    This was in the Nightbane War.

    When I was facing a Nightraider, who is half dragon, I used Scale Rot.

    When the spell hit, it did the non-triggered low damage Earth hit, not the Element X hit.

    I don't know much about my computer, so I can't get a pic... All I know is that I'm using Mozilla Firefox Version 1.5.0.6

    ~Jartix

    If it was supposed to allow the dragon-type trigger, it would have dragon in the name or it would be coded that way.
    ~Ghost


    < Message edited by Ghost of Cloud -- 9/2/2006 13:18:57 >
    Post #: 2
    9/2/2006 13:19:35   
    HK 47
    Member

    i was wearing NMP, NMS and Darklaw and the flower guest, attacked a shirrig, he countered me at third hit, and attack menu didn't pop up nor did he attack
    AQ DF MQ AQW  Post #: 3
    9/2/2006 20:38:05   
    potymon
    Member
     

    when i go alphanax, after defeating a monster keep on freezing !!fix it!
    Post #: 4
    9/2/2006 22:54:22   
    blackstar989
    Member

    This is a bug in two ways. one bug is mostlikely already known but i'll name it anyway.

    The "Grunt" description states that it was re-animated by a necromancer, being re-animated is what undead is. therefore the grunt should be classified as undead.

    because of the error in description it doesn't appear to have this next bug but does.
    the vampire slayer armors "Vampire Strike" and "Shake & Stake" should both do damage to it. this is the part of the bug that may be known about.
    AQ  Post #: 5
    9/3/2006 4:38:53   
    james_knapp
    Member

    In alnaphar i was fighting an orc hoard. It or they had 64 hp left so i used an undead mutant. After one hit out of the five their hp was reduced to 1 then the four other hits DID hit but their hp remained at 1. Then, i died.

    (Not a bug. You have to defeat twelve orcs before the horde is defeated.)

    < Message edited by Chii -- 9/11/2006 15:00:36 >
    AQ  Post #: 6
    9/4/2006 13:26:35   
    PenSword
    Member

    I was in Anaplar(spelling) looking for the shadow armor, I fought an Undead Warlord. (I think that's what it was called, it looked exactly like the Skeletal Knight except it had an axe and it's name eneded with Warlord.) I beat him and then I went to the loading screen to face another monster, but I never loaded him. I mean everything else but the monster is ready. I'm still waiting for it to finish loading him, please fix it.
    Internet Explorer
    X-Gurdian Account
    Weapon: Crystal Seed
    Sheild: Monster Claw
    Pet: FireWere
    Guest: Hallipax
    AQ  Post #: 7
    9/5/2006 6:08:36   
    Shinseiki
    Member
     

    i too had the same problem... i was wearing Necromancer cloak , Daimyo (guest) , Gogg (pet). The menu button didnt pop out at all.
    quote:

    ORIGINAL: general tommy

    i was wearing NMP, NMS and Darklaw and the flower guest, attacked a shirrig, he countered me at third hit, and attack menu didn't pop up nor did he attack

    AQ  Post #: 8
    9/7/2006 2:14:02   
    Daemon_100
    Member

    I pressed the battle Monster button and a Umazen attacked me. But instead of saying "Umazen" it said "Umazen.com". I was worried it was a bug.

    (Not a bug. Shockingly, that's the name of the monster.)

    < Message edited by Chii -- 9/11/2006 15:02:01 >
    AQ  Post #: 9
    9/8/2006 14:14:10   
    averial
    Member

    This happened on Char ID 1031613.

    While fighting the Syphon Dracovampiress in Nightbane's Keep, she did her thing with stealing levels and stat points as normal. However at the end of the battle, I did not receive all of my str points back. I was shorted 30 of them! I have not finished the keep yet, so I do not know if I can go back and re-earn the str points. I will try and edit this post with the results, however I do not look forward to re-spending the gold on the stat points, because at 100 on str, it's going to cost me a chunk of change.

    Equipment on at time:
    Nightmare Plate
    Darklaw
    Nightmare Shield
    Warrior's Edge

    Guests/Pets: E, Fairy Godmother.

    Notes: Using Firefox 1.5.0.6 and Flash 9. This only happened the first time I battled SD. I did have my stat sheet up at the end of the battle before it restored my stats and levels because I wanted to make sure it restored my stats and levels. Since, I have not had my stat sheet up at the end of battle as I think this may have caused the glitch. All of my stats have been restored with the exception of the missing str points at the beginning of the next battle.
    EDIT: My Character page still lists my str at 130. I'll try logging out and logging back in to see if it restores the missing str points before I go spending a chunk of change. EDIT2: Logging out and logging back in restores the stat points.

    < Message edited by averial -- 9/8/2006 15:45:12 >
    AQ DF MQ  Post #: 10
    9/9/2006 2:38:39   
    Eradragon
    Member

    When battling an Alpha Dracowolf, it says sometimes that they regenerate 50% of my last attack. The problem with this is, I hit a 30, they regenerate 16, and not 15. I hit a 4, they regenerate 3. Once I hit an 18, and it regenerated 10. Basically the are regenerating a little more hp than they should. It's not a HUGE bug, but it's still a bug.

    (Hm. The regeneration formula probably takes your damage and divides it by two, rounds it to the nearest integer, and then adds one. Might get tweaked.)

    < Message edited by Chii -- 9/11/2006 15:03:47 >
    AQ DF MQ  Post #: 11
    9/9/2006 16:22:16   
    trew879
    Member

    When finished battling a monster sometimes it keeps saving and i have to start over
    Please Fix

    < Message edited by trew879 -- 10/21/2006 19:24:27 >
    AQ DF  Post #: 12
    9/10/2006 1:25:35   
    PhaedrusZ
    Member
     

    I know that this has been posted before, but I'm having a huge problem with Syphon Dracovampiress. After the battle (I seem to encounter them a lot lately), my stats are only going back to a fraction of their original levels. I pulled screenshots if you want them, but this should be sufficient. This becomes a problem since I have several charged armors that I keep up in case of a battle emergency. In order to get my stats back I have to reload the page and log back in. Logging out/logging in doesn't seem to work. This causes me to lose my charges, unless I want to pay a lot of gold to retrain 100 stat points. Very frustrating...


    here are my stats at login: (Lvl 92)
    Str:130
    Dex:130
    Int:100
    End:100
    Cha:0
    Luk:0

    Here are the stats at the end of the Syphon battle:
    Str:75
    Dex:45
    Int:25
    End:0
    Cha:0
    Luk:0

    And this is what I'm at after the file is saved:
    Str:110
    Dex:70
    Int:80
    End:100
    Cha:
    Luk:

    I thought this may be a progressive healing thing, but those stats stay there after a dozen random battles...

    Oh, and BTW, I'm also seeing the periodic flashing "need 0" on my XP bar as reported earlier.
    Post #: 13
    9/10/2006 13:21:50   
    HomicidalManiac
    Member

    i was fighting the shirrig with nmp and darklaw and i attaked it hit him 2 times then he hit me and screen froze i had big cole as pet and the sunflower thing as guest

    < Message edited by HomicidalManiac -- 9/10/2006 13:24:47 >
    AQ  Post #: 14
    9/11/2006 16:25:42   
      In Media Res
     ALMOST HALLOWEEN


    Acid Spitters don't display damage type (Melee/Ranged/Magic) for their attacks.


    When you freeze Fire Orbs (aka Geoto Mercenary) in the clan war and they become Ice Crystals, the name and description changes to that of the Ice Crystals (not Geoto Mercenary).
    EDIT: Not fixing this bug. Way too much trouble.

    (Above edit by Captian Rhubarb)

    EDIT 2: Showing my complete, total ignorance of programming, how about making the name-changing dependant on it's current name being "Fire Orbs"?

    (Above edit by me)


    < Message edited by In Media Res -- 10/14/2006 16:13:58 >
    AQ  Post #: 15
    9/12/2006 14:47:46   
    Pesha
    Member

    After I have defeated a Burp King I can't see what It stands on the text. So I can't choose wether to let him go with me or not. And if I just press next he is still with me so he removes my other guest.

    Clickie!

    < Message edited by Pesha -- 9/12/2006 14:49:44 >
    AQ DF MQ  Post #: 16
    9/12/2006 19:54:14   
    Kasuto
    Member

    (this is for DragonFable) In the recently added Scale N' Stack quest, going left and getting to the second Aqueevil with the 2 Aqueevils and Puddle, well I checked how much damage each one was supposed to do, then I attacked the Puddle and the 2 Aqueevils hit 49. Is that supposed to happen?The stats at first said they do 3-9 i think, then it said 8-30.And I did it a second time, then it said the 2 Aqueevils do 6-6 damage and the puddle did 5-7 damage. I think thats a bug. Oh and are the water elementals supposed to say "Monsoone Elemental" then say "Loogie"?

    Also, with the stackable items, its purple so its supposed to be a DragonAmulet only thing, yet I have no DragonAmulet, so why can I still own it and sell it?

    Oops, nevermind that thing on the stackable items. I guess I'm colorblind lol.

    http://forums2.battleon.com/f/tt.asp?forumid=90

    < Message edited by Chii -- 9/13/2006 8:52:55 >
    AQ DF  Post #: 17
    9/14/2006 17:13:02   
    Flood_Master
    Member

    A lot of monster parties (2+) have a monster that is still standing after you defeat them. Is this fixable?
    AQ  Post #: 18
    9/15/2006 12:33:48   
    Vraelon
    Member

    I was battling a Plodd(2) and was losing(purposely ) so I could become a lich.However,the first attack of the two killed me,and I was about to press the become a lich button when the other attacked,removing the button from the screen.
    AQ  Post #: 19
    9/15/2006 17:17:59   
    Compassion
    Member

    When fighting with a Rotting Corpse Zombie the element of the Big 100K doesn't change to light I was using Night Shield and Werepyre Form next to this...
    AQ DF  Post #: 20
    9/17/2006 9:18:43   
    Fireflight
    Member

    While in Nightbane's castle, I got to the part where you can opt to keep fighting or leave. I opted to keep fighting four times, but on the fourth time, nothing loaded. The scenery and my stats loaded as if a battle was in progress, but no characters loaded, and nor did the monster or its stats... I'm using Inernet Explorer with Flash 9.
    AQ  Post #: 21
    9/17/2006 10:11:31   
    Vraelon
    Member

    Fighting Undead Giant(2) as a lich and used terror,getting the magic defense into minuses.Is this supposed to happen?

    http://i113.photobucket.com/albums/n213/Vraelon/AQBUG-MINUSTOMAGIC.jpg

    (No bug. Terror has a chance to reduce monster defenses. They can be reduced into the negatives.)

    < Message edited by Chii -- 9/17/2006 10:21:04 >
    AQ  Post #: 22
    9/17/2006 23:28:43   
      In Media Res
     ALMOST HALLOWEEN


    I was using Wind Orb against Orc Horde, and it kept flickering on and off based on which monster I hit.
    AQ  Post #: 23
    9/19/2006 23:32:04   
    DaveJ
    Member
     

    Fighting Wolfwing no matter how much damage I did to him a hit, sometimes in excess of 120, his wereworf-esque regeneration ability only healed him 1 pt every time even though it says in the caption he heals 1/2 of my last attack... There is a good chance I wouldn't have been able to beat him were it not for this bug.
    AQ  Post #: 24
    9/21/2006 12:09:44   
    mturf
    Member

    this has happened to me many times, i don't think it's a monster bug but as it only occurs when fighting one monster, hence why i'm here.
    unless i actively play in the AQ window (not leaving it idle, playing df/another aq window simultaniously, or posting in the forums) when fighting a pheron (lvl 85), the game runs really slow, freezes up, and stops responding.
    i have no idea on how long it takes this to happen, i only remember once it freezes up, but it's no longer than thirty minutes.
    this has happened to me at least 8 times. character linked on my forum account, using NmP, EoC, AuS and Daimyo pet (no guest or misc item) every time. most recent flash version on every occasion, windows internet explorer ver.06. 1meg broadband connection. recently cleared cash/temp internet files. graphics running medium/low.

    ~M~


    < Message edited by mturf -- 9/21/2006 12:11:00 >
    AQ DF MQ AQW Epic  Post #: 25
    Page:   [1] 2 3 4 5   next >   >>
    All Forums >> [Artix Entertainment Games] >> [AdventureQuest] >> AdventureQuest Bugs >> Monster Bugs - read the topic rules BEFORE posting.
    Page 1 of 6212345>»
    Jump to:



    Advertisement




    Icon Legend
    New Messages No New Messages
    Hot Topic w/ New Messages Hot Topic w/o New Messages
    Locked w/ New Messages Locked w/o New Messages
     Post New Thread
     Reply to Message
     Post New Poll
     Submit Vote
     Delete My Own Post
     Delete My Own Thread
     Rate Posts




    Forum Content Copyright © 2018 Artix Entertainment, LLC.

    "AdventureQuest", "DragonFable", "MechQuest", "EpicDuel", "BattleOn.com", "AdventureQuest Worlds", "Artix Entertainment"
    and all game character names are either trademarks or registered trademarks of Artix Entertainment, LLC. All rights are reserved.
    PRIVACY POLICY


    Forum Software © ASPPlayground.NET Advanced Edition